Archive

Posts Tagged ‘Troubleshooting’

Adding languages for Office 365 update downloads in Configuration Manager only adds the first language

October 13, 2017 Leave a comment

During a recent customer visit I was asked to troubleshoot an issue with Office 365 language specific updates. This blog post outlines my findings and the solution.

The customer is running a Current Branch 1706 environment and needs to support Dutch and French languages for Office 365, next to the default English language. As such he wants to ensure all updates for these three languages are properly downloaded. To achieve this the engineer is following the procedure as documented here.

Background

Let’s first have a look at what is documented the TechNet Docs.

Beginning in Configuration Manager Current Branch 1610, you can add support for Configuration Manager to download updates for any languages that are supported by Office 365, regardless of whether they are supported in Configuration Manager.

The documentation contains a detailed procedure on how to add support to download updates for additional languages. This is done through WMI.

Configuring additional Office 365 update languages is a site-wide setting. After you add the languages using the procedure, all Office 365 updates are downloaded in those languages, as well as the languages that you select on the Language Selection page in the Download Software Updates or Deploy Software Updates wizards.

 

 

Initial findings

As the customer did not want to select the additional languages in the Software Updates wizard each month he opted for the site-wide setting and required modifications. As per the outlined procedure the required changes were made in WMI.

Notice in the screenshot below the values are specified exactly as per the screenshot in the TechNet Documentation.

clip_image002

Based on these settings the updates for Dutch and French should be downloaded. English does not have to be specified and is always downloaded. However, when checking the sources in the Software Update Deployment Package, only English and French updates have been provisioned. Dutch is missing.

clip_image004

During a second test the language tags in WMI were switched, so Dutch was first in the list.

clip_image005

After the download completed the Software Update Deployment Package source folder only contains English and Dutch updates. French is missing.

clip_image007

It appears as if only updates for the first language specified are being downloaded.

A few runs later (going through some variants with delimiters etc.) we tested with the following values in WMI

clip_image009

After the download completed we checked the Software Update Deployment Package source folder again – and finally updates for all three languages are properly provisioned.

clip_image011

 

 

Conclusion

The screenshot in the TechNet documentation is misleading as the language tags are separated with a comma and a space. Based on our above findings the language tags should be separated with a comma only, the space should be omitted for this to work when specifying multiple languages.

Side note: the TechNet documentation also mentions Use the following procedure on the software update point at the central administration site or stand-alone primary site. This is not correct as the procedure needs to be executed on the site server, not the SUP.

Hope it saves you some troubleshooting time!

Tim

Advertisements

ConfigMgr 1706 – BgbServer.log expecting more data from client errors

September 29, 2017 2 comments

After upgrading a Configuration Manager Current Branch environment to 1706 you may notice a lot of Expecting more data from client errors in the BgbServer.log .

This log records the activities of the notification server such as client-server communications and pushing tasks to clients. It also records information about online and task status files generation to be sent to the site server.

20170928-BGBServer

Feedback from Microsoft indicates this is related to the client not sending the final packet via TCP channel somehow or when the ccmexec service on the client restarts. The good news is that these events are harmless and are not impacting any functionality.

Logging improvements in future releases should fix this and avoid BgbServer.log from turning red.

Hope it helps!

Tim

*** Update 20/10 ***
I logged a case for this with Microsoft (ID 3141726) which changed status to Resolved just now. Expect this to be fixed in the next CB release.

Advanced Threat Analytics triggering Symantec Endpoint Protection alert

August 17, 2017 Leave a comment

During a recent proof of concept implementation of Microsoft Advanced Threat Analytics the customer reported a large number of workstations suddenly displaying a notification from Symantec Endpoint Protection.

The notification was indicating unusual traffic with packets originating from the ATA Gateway we had just implemented. An example screenshot is shown below:

image

As the main purpose of the ATA Gateway is to capture and inspect network traffic from the domain controller, the customer was unsure whether this was legitimate traffic or not. Why would an ATA Gateway send packets to a large number of workstations on the network?

Luckily we could confirm it is legitimate activity – and the rules for Symantec Endpoint Protection could safely be adapted to avoid have these popups again.

Some more background

Next to capturing the Domain Controller network traffic one of the other functions of the ATA Gateway is to perform resolution of network entities. When we inspect the ATA Gateway log files we clearly see the resolution steps taking place. It is the RPC NTLM resolution that actually triggered the alerts on the endpoints.

image

Backing up our statement above is a note which can be found in the ATA Prerequisites documentation.

clip_image001

Conclusion : make sure to check your other security solutions in place when implementing Advanced Threat Analytics. Without implementing and/or tweaking some rules you may accidently trigger some alerts on a large number of systems and make some security folks nervous.

Until next time!

Tim

ConfigMgr 1606 – Unable to modify language configuration

September 1, 2016 Leave a comment

When running Configuration Manager current branch 1606 you might run into a situation where you cannot modify the language configuration of a site. The option is simply greyed out, preventing you from adding any client or server languages.

image

The reason to why this is happening can be found in the ConfigMgrSetupWizard.log (hat tip to fellow MVP Roger Zander for pointing this out). Here we see an entry indicating that setup detected that client piloting is enabled for the site and as a result the modify language configuration option will be disabled.

image

So if we want to make any language modifications we need to promote the pre-production client to production first. This can be done in the administration workspace in the updates and servicing node.

image

Once the previous step is completed we can run the Setup Wizard again and in Site Maintenance the modify language configuration option is no longer greyed out. Adding client and server languages is possible.

image

 

Conclusion: you cannot change the language settings as long as the pre-production package has not been promoted.

The underlying reason for this is that we cannot apply language pack MSP files for the newer client to an older client version. When in piloting mode the new binaries have been updated everywhere, except for the client folder for production. Adding new client language packs would copy the newer language pack MSP files from cd.latest to the client folder that still has an older client version. These language pack files are not compatible with that older client – and as a result would be deleted.

Hope it helps!

Tim

Configuration Manager 1511 – Client hangs on initializing during OSD

March 11, 2016 Leave a comment

A customer that recently upgraded to Configuration Manager 1511 CB ran into an issue with deploying newly captured OS images. The task sequence is hanging on client initialization and fails eventually. Images captured before the upgrade could still be deployed without any issues.

This blog post details how we resolved this.

Symptoms

When deploying an OS image captured using a Build and Capture task sequence in Configuration Manager 1511 the client hangs on the client initialization step. In the smsts.log we see an entry Waiting for the CCMExec service to be fully operational . After that there is one more entry referring to loading TSRES.DLL .

CB1511-OSD_Bug-ClientInitializing

 

Issue

This is a known bug in Configuration Manager 1511 which is logged on Connect (ID 2153746).

Feedback on the connect item indicates this will be fixed in an upcoming update to the Configuration Manager current branch. The workaround for now is to not include the client in the image.

Note : in 1602 Technical Preview this issue has already been fixed.

 

Workaround

There is another way to work around this if you do not want to pursue the alternative not to include the client in the image.

For this you would need to modify the Build and Capture task sequence to include two additional steps:

  • Step 1 : run ccmrepair
  • Step 2 : reboot the system
    An example is shown in the screenshot below.

image

When deploying the newly captured image using the modified task sequence the client will no longer hang on initializing.

Once the next update of Configuraiton Manager CB is implemented in your environment these two steps can be removed again.

Hope it helps!

Tim

Update for Windows Update Client addresses ConfigMgr 2012 Update Scan Issue – Windowsupdate.log Error 8007000E

June 3, 2015 1 comment

Exclamation-iconYesterday Microsoft has released an update for the Windows Update client. This relates to the issue with Windows 7 and Software Updates which I blogged about a few weeks ago.

This is the KB article: Windows Update Client for Windows 7 : June 2015

Interesting: the KB Article mentions this update does not only address the out-of-memory issue but also contains general improvements made to support upgrades to a later version of windows.

If you have Windows 7 x86 clients in your environment the best approach would be to release this update in your environment as soon as possible. Important : you need to install the hardening update KB2938066 on your WSUS servers prior to releasing this update!

Hope it helps!

Tim

ConfigMgr R2 SP1 upgrade does not clean up previous Cumulative Update entries in Control Panel > Programs and Features

June 2, 2015 Leave a comment

Hi All,

Just a quick blog post on a small anomaly with Configuration Manager R2 Service Pack 1.

Description

When upgrading an existing Configuration Manager site it seems the Installed Updates entries related to prior Cumulative Updates are not properly cleaned up. After upgrading a site the end result for Installed Updates looks like this:

image

The above example is based on a site that was up to Cumulative Update 5 – but the same happens with earlier released Cumulative Updates.

Although this is not really an issue and more cosmetics, it is something that could have been handled more properly by the Service Pack installer. A scenario where this potentially may cause unwanted effects is when using this information in your queries (collections, etc.).

Workaround

The entries displayed are read from the registry. The screenshot below shows the entry in the registry for the particular cumulative update:

image

I used the following steps to clean this up:

  1. Start the Registry Editor (regedit.exe)
  2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall .
  3. Locate the key for CU5 (see screenshot) and take a backup (right-click > export).
  4. Delete the key for CU5.
  5. All done – the entry is no longer displayed.

Note that this cleans up the cosmetics part only – any other leftovers (if any) from Cumulative Updates (and alike) will still remain on the system.

Until next time!

Tim